Jump to content
06mega

real time programming

Recommended Posts

hello Brian,

   just started to try out my real time adjustments wanted to change rail pressure tried to send and got error code 15211 real time request failed. could you help me out with this please?

Share this post


Link to post
Share on other sites

Greetings! ComMod plugged in? Also please confirm you are updated to the newest software.

 

Please keep me posted!

Thank you!

 

Share this post


Link to post
Share on other sites

yes to both i just updated to the latest GUI software the 2.0.0 and commod is plugged in  i have the 06 model and had to install the plug for the data link or whatever i tried unplugging and plugging back in each connection to make sure had good connection and still got the same thing. i will have to check plug i installed to confirm connection there but i soldered the connections so should be good any other ideas still same 15211 error code thanks charles

Share this post


Link to post
Share on other sites

yes ECM was programmed at level 3 and level 5 are the two that i have tried it on with the same error code on both

  • Like 1

Share this post


Link to post
Share on other sites

Thank you Charles! We will see what we can come up with. :cheers:

 

Share this post


Link to post
Share on other sites

hello Brian,

thank you for your response i tried again tonight and got the same error but i also noticed tonight that the tow/haul light illuminated or came on after i tried to send it and failed i am wondering if some how got the wrong wire when installed data link plug or something i don't know. i know i followed you install pics and instructions to a t ill have to double check that Thanks charles

Edited by 06mega
misspelled word

Share this post


Link to post
Share on other sites

every time I try to send it like the first time will turn on tow/haul second time will turn off OD then back to normal on third time like i am pushing the button on end of gear selector

Share this post


Link to post
Share on other sites

Hello Brian,

Thank you but on our 06 model trucks we didn't have the service bus on it we had to tap into the wiring harness and wire it in ourselves for ComMod use i just found the pics that i had printed off from you we had to tap the green and blue wires to install service bus connector checked and compared what i had done to pics and was all the same so not sure on this issue.

Thanks Charles

  • Like 1

Share this post


Link to post
Share on other sites

Indeed I shared the wrong link. I am not in my office so apologies. Thank you for confirming the hook up!

 

My programmer tells me to search for a connection issue to the ComMod.

Tow haul and OD delete issue? I would expect a member who is a professional UDC Pro tuner may weigh in on this one.

Thank you Charles!

 

Brian

 

  • Like 1

Share this post


Link to post
Share on other sites

ok i hope so too thanks for the help so far Brian i really appreciate it

  Charles

  • Like 1

Share this post


Link to post
Share on other sites

Charles,

Any luck on the tow/haul OD off issue?  I remember hearing about this issue before with a different tuning platform but when the truck was flashed since they dont support real time.  If I recall right it was an error that happened on some trucks and not others.  It had to do with one of the fuel limiters being enabled or disabled.  You might check your file against stock and see if any of your radio button limiters are set different than stock and try changing them one at a time if so.  I'll keep digging and see if I can find the post on it.

  • Like 2

Share this post


Link to post
Share on other sites

Ha!  Just found the post but I'm not sure its anything we can change at the moment.  It might have to be fixed higher up the chain.

Quote

It is related to switch 7871 "Limiter B". Please reset this switch to "Enabled" and your issue will be resolved.

I would still double check your tune against stock and see if you can find something.  More information would be needed to see if 7871 is included in our parameters and what it is called on this platform.

  • Like 2

Share this post


Link to post
Share on other sites

oh ok thank you jadlmark ill have to look at it and make sure and check the tune against stock and see just got back from vacation thanks again

Charles

  • Like 1

Share this post


Link to post
Share on other sites

Hello,4play

i am not real sure how to compare the tunes do i have to use a laptop in the truck cause i tried using the sd card on my home computer using the udc program it only lets me do demo mode I am going to try again in a bit .Or do i need a dongle i didn't think i needed one but maybe i do any info would be greatly appriciated

                         Thanks Charles

Share this post


Link to post
Share on other sites

Charles are you running a revo tune, udc or udc-pro?

The real time adjustments on the touch will only work on the canned tunes (revo,tnt).  If you are using a udc or udcp tune then you would need an rtp or rtg file to make any real time adjustments.

Share this post


Link to post
Share on other sites

I'm not actually sure if there is any real time capability for a regular udc tune, I don't think there is.

Share this post


Link to post
Share on other sites
27 minutes ago, Rob D said:

I'm not actually sure if there is any real time capability for a regular udc tune, I don't think there is.

You are correct Rob :thumbsup:

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Bad assumption on my part. Its still a little strange that it would affect tow/haul. 

Share this post


Link to post
Share on other sites

Is it happening when you try to flash a tune or just change real time settings. 

Share this post


Link to post
Share on other sites

Hello 4play,

 I am running the newest UDC pro RT 2.0.0 GUI software the tow haul light does come on when i flash it but goes off when done programming just running a canned tune from the smarty touch right now running between SW 3 and SW 5 both have the RT  on the screen and have timing and rail pressure for options as well as send once or every key cycle so when i try to send the RT change it will show failed and give me error code 15211 and tow/haul light will illuminate if i try again OD off light comes on then again light turns off. Should the tow/haul light illuminate while programming never really noticed it before.had to wire in the plug for ComMod into wiring harness which all looks good hope this gives you guys the info you need to figure this out if you guys have any more questions let me know

Thanks Charles

Share this post


Link to post
Share on other sites

It does seem like the tow/haul light comes on when flashing a tune but goes off afterward.  I'll have to check the next time I flash.  Should be tomorrow if I get time to do some adjustments.  I can try simulating the rt changes this weekend and see how it looks.  I'm sure I was able to send an rt change (adjustable options Timing 1-3, RP 1-3, TQ 1-3) with a canned Revo tune loaded.  I know there are some discrepancies  between the 04.5 and 05 but we shall see.  What firmware version is on your touch?  

 

You will need a UDC Pro dongle to actually create tunes to answer your previous question.

 

Mark

  • Like 1

Share this post


Link to post
Share on other sites

Hello Mark,

the only adjustable options on the canned tunes i have are timing and rail pressure do not have torque on my 2006 for RT options not sure what you mean on the firmware loaded the 2.0.0 firmware from site thank you for the info since your a professional tuner i may have you make me some tunes after i get my new injectors installed. My truck is a 2006 5.9L with automatic trans 48RE.

Thank you Charles

Share this post


Link to post
Share on other sites

I see where my confusion has been coming from.  I've been helping another Charles with an 04.5.  He is working on RT tunes as well so its been easy to get you two mixed up

 As long as you are above 1.3.5 the Com Mod is enabled.  I'll do some more digging this weekend.

Unfortunately I am currently not set up to sell tunes but I know there is at least one other pro tuner here that could probably help you out with that.  Hopefully I'll have everything in place soon.

Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×