Jump to content

Recommended Posts

I am adding this update to my tuner I have not updated previously is there any files I need to remove before updating?

Share this post


Link to post
Share on other sites

also tuner will fail when tring to program ecm and also when tring to return to stock the first time and most times it will accept the tune the second time. and when taking the sd card out and re inserting it . it wont reconize the sd card unless i re insert it about a dozen times . took it to a shop and the said maybe you need a new tuner but couldnt explain why. also having lack of power when tuned . so i thought i needed to update it and the file i down loaded wont unzip. do i need to delete files off sd card before updating. has never been update or seen a computer till today since i bought it 10 months ago.

Share this post


Link to post
Share on other sites

Good morning!

 

Fail?

 

error codes?

 

year of truck?

 

Lack of power? What do you get on the rollers and in which SW level? Other mods? Please share details!

 

 

Share this post


Link to post
Share on other sites

When I try to program it to any tune or try to return to stock runner will fail and say returning to stock. Sometimes it will return back to stock or fail again. 

 

Truck is 2004 5.9 cummins 3500 dually. 

 

No no error codes 

 

after quarter throttle there's barely any pick up

 

arp studs,banks full intake system, air dog and 4 in exhaust 

 

 

Share this post


Link to post
Share on other sites
23 minutes ago, jwagz420 said:

When I try to program it to any tune or try to return to stock runner will fail and say returning to stock. Sometimes it will return back to stock or fail again. 

 

Truck is 2004 5.9 cummins 3500 dually. 

 

No no error codes 

 

after quarter throttle there's barely any pick up

 

arp studs,banks full intake system, air dog and 4 in exhaust 

 

 

 

As to your power loss I would not be able to diagnose your truck issues. What do you see when monitoring your PIDs. RP falling off? Sounds as if you have some truck issues. Not sure I understand what you are saying but if it is loaded properly, you sw level choice will not return back to stock.

 

If it is having issues loading you should see an error message on the display.

 

This guide should help.

 

Thank you!

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×