Jump to content
BILT-IT

Lost "transmission" selection with newest update

Recommended Posts

Anyone else lose the transmission PID's with the newest update? I have, can no longer view any transmission PIDS (i did have it before as i compared the smarty trans sump temp with my added sump temp gauge).

 

Maybe i need to redownload? I tried unplug/plug in the display but no change.

 

2003 QCab 5.9C

Edited by BILT-IT

Share this post


Link to post
Share on other sites

Hi Will,

 

Smarty Touch Software update, 10-27-15

 

http://smartyresource.com/smartytouch-3.aspx

 

What is new?

- MY 2016 pickup and C&C are now supported

- MY 2013 to 2015 pickup and C&C:

- Improved compatibility for new Chrysler updates

- Addressed idle shutdown

- Revised VGT settings

- Addressed several DTCs like P026*

- Revised Duration texts for MY 2010+

- Addressed On the fly issues with MY 2010 – 2012.

 

Thank you!

Share this post


Link to post
Share on other sites

I guess I am confused. I have an 04.5 Dodge and do not have any trans PID's, and as far as I know 03 to 05 there are no trans PID's available on the smarty as of yet, is this correct and how are people saying they had trans PID's and then they disappear and then get them back by reinstalling the update. Seems like all these new updates are just for the newer trucks and have nothing to do with the older ones. Lets get this fixed

Share this post


Link to post
Share on other sites

They must have changed the list sometime since june, it used to show trans pids for the 03-04. My guess is it seems they are hit and miss if they show up or not so they just took them out.

 

I know i have them showing up on my late 03.

Share this post


Link to post
Share on other sites

One of the main reasons that I sold my SSR and purchased the Touch is so that I did not have to buy extra gauges as I tow my fifth wheel and also my truck is a DD. During my research, I found that there were posts that had the MY03 with trans sump temp pids and thought that they were just not available at the time of the post.  Sooo at Brian's recommendation, I took the plunge.  Installed the touch with the latest 2.0 SW and WTF!  No Trans Temp!  I was willing to take the $155 hit for the EGT sensor but am very disappointed to find that the touch does not have the trans temp for MY03.

Share this post


Link to post
Share on other sites

Hi Robert,

 

indeed different years of trucks offer different available PID's.

 

Keep in mind that external trans temp sensors will be released.

 

Thank you

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×