Jump to content

PAULTURNER911

Members
  • Content count

    21
  • Joined

  • Last visited

Community Reputation

10 Good

About PAULTURNER911

  • Rank
    Junior Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. PAULTURNER911

    Long crank/ Low rail pressure on start up

    I already got everything replaced (not the cross tubes though). Truck starts and seems to idle fine, holds rail pressure..... I was just picking your brain on the outcome. Basically does everyone lose MPG when theyve gone form pensecola injectors to Bosch??
  2. PAULTURNER911

    Long crank/ Low rail pressure on start up

    Stock. I meant in general what should someone expect to pay turn key?
  3. PAULTURNER911

    Long crank/ Low rail pressure on start up

    Whats a reasonable cost these days?
  4. PAULTURNER911

    Long crank/ Low rail pressure on start up

    No the truck did not start with the fca unplugged after sitting over night.
  5. PAULTURNER911

    Long crank/ Low rail pressure on start up

    I did run the truck with the fca unplugged. a bit chattery.... I also dried the location of the banjo bolt, there was a small hole I couldnt get a rag in, maybe a q-tip? But I didnt see any build up, Id think if it was leaking under that kind of pressure it would be weeping at a decent rate?!?!?
  6. PAULTURNER911

    Long crank/ Low rail pressure on start up

    I havent tried to start it "cold" or after sitting all night with the FCA unplugged. BUT, I did unplug it and monitor rail pressure and it was around 27k. I opened the banjo bolt on the PRV and started the truck. It was wet when I opened it but didnt produce any more fuel while cranking or running. I suspect the small amount of fuel was tied in from the return?!?! Thanks for your input, it all helps.
  7. I have an 04.5 with 170k miles runningthe SW3 tune. Ive started to get long cranks if the truck sits overnight. The Autel shows my rail pressure building slow while cranking, sometimes needing a shot of starter fluid. Once its started with or with out help, it maintains the set points specified buy the scanner. 6500 at idle, 10k under light throttle, the rail pressure reads 27k if I unplug the FCA. Buzz killed the injectors, all passed. Lift pump has plenty pressure. Clean filter every oil change.... What else should I look at before throwing a CP3 or injectors at it? Could anyone explain id the PRV could have anything to do with this? Thank you
  8. PAULTURNER911

    Updates?

    How often are you pushing updates for the S-06? What/when was the latest update? How do you tell if you have the latest?
  9. PAULTURNER911

    Newb

    I've searched but couldn't find anything... What kind of torque numbers do the catcher sw settings give?
  10. PAULTURNER911

    Newb

    If I turn the WG setting to off, will I booost higher? I have the HO 325/600. I cannot get a drop over 30 since I put SW3 on it. Before Ive seen it spike to 32psi. Also I here a bit of rattle, should I try to pull the TM down to 3?
  11. PAULTURNER911

    Newb

    What kind of boost should I be reading? The line is connected to the top of the manifold elbow and Ive always seen it spike to 32 and hang just below 30. I was reading some people boosting 40+ with a smarty on the 351. What should I expect at SW3?
  12. PAULTURNER911

    Newb

    I understand. Dylan was able to clear that up for me. You guys have been great! Thank you
  13. PAULTURNER911

    Newb

    Per this sheet-http://smartyresource.com/downloads/manuals/RevoSW_Instructions.pdf Timing 2 is not default but WILD Rail Pressure is not default but MILD Im confused by #0 default, #1"stock", and your (default) as none seem to match. Could you explain?
  14. PAULTURNER911

    Newb

    What SW and PoD would you suggest to net me a SW3"ish" tune and not risk pushing up on the limits of my sad 48re. Cant thank you guys enough for the help in beating this learning curve. Thank you!!
  15. PAULTURNER911

    Newb

    Great! Read it! Im still learning the results of changing some of the optional settings. I will run SW3 (AT friendly), TQ1 (AT Friendly), Timing 2(cooler EGT, better MPG) The other settings should be left as default correct? Also, Ive seen people say to run a higher SW and use PoD to pull it down and gain fuel mileage, can you confirm? Thanks
×